[转载]个股相对大盘强弱指标_骄阳如雪

思想必要元素

求教于完全地,授权中有缺乏个股对立大盘强弱依等级排列的目标.

通常注意到的K线,按生水垢分配,求体积法。支持物不了解。不见授权,二
现时想照本身的零碎,作为一份对立于大盘强弱目标。但不变卖能否有技术求教于各位都。据我的观点存根采取军事行动需求这么的目标,尤其

1:DZH是人家功能强大的雷达装置,是你希望的:
功率雷达装置

规律:
相比一份和一份市集的力气

用法:
弧线谋求发迹,人越陡。,代表一份是一种微弱的一份。。
选择强势一份目录后果相当正当。,请好好应用它。

V1:=(C / REF(C,1)-indexc/ref(indexc,1))*200;
方式:总结(V1,0),colorwhite;
拉德:马(RAD,30),coloryellow

2:对立强弱目录=股价/目录

数值程度无价值,动摇浮现是很重要的。。高涨的一份对立强弱目标,竟,具有较强的一份目录的相比。

3:我用一只一份,三十天或VS等比中数,等比中数补充物
两条弧线,一言可尽看出个股和大盘强弱相比

4:谢谢你楼上的回答。
毒花兄提到的功率雷达装置,在大打趣话中未查明,而中号桶射中靶子公式集核心,还无法在相互作用上显示.因而也不识后果若何.
帝国兄的解说马上我要表达的意义.执意要找”对立于目录不息可怕的的一份”.看帝国的意义即将到来的目标应该是自设的吧.
mafia00,我希望的也同样的的这么两条路线.再不熟练的是等比中数值.自行车也要短非常的.我设想的样品,它应该是钟形的。一份越强,喇叭越大,越响。,mafia00兄弟姐妹般的本身发明的目录。我不变卖稍微涉及

————————————————————————————————–个股与大盘强弱相抵目标-(复杂不含糊的源码)

本文出生于:抱负法庭

在非常使习惯于下,咱们应用图形叠加法来相比一份的走势。,但普通的图形将脱臼,相抵后果普通不太好。,前时期的长短时期应网友查问,列出的目标,图中排好队伍股市K线,在时期的长短时期内的统计资料的按照。时期限制元素n可以恣意设置。。

行为准则列举如下:
使再次发生心甘情愿的到有纸夹的笔记板行为准则
无上的目录H',LINETHICK0;
最低的的核心:核心,LINETHICK0;
吐艳目录:indexo,LINETHICK0;
结束的目录:大盘结束的价,LINETHICK0;
大盘涨幅:(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100,LINETHICK0;

分离地一份的补充物:=(C-REF(C),1))/REF(C,1)*100;
我:=计数(市集高涨<个股涨幅 ,N);
大盘:=(INDEXC-REF(INDEXC,n))/REF(INDEXC,N)*100;
一份:=(C-REF(C),N))/REF(C,N)*100;

IF DISPSTATUS=2 and 大盘<个股 THEN DRAWTEXTREL(10,570,最近, numtostrn(N,0) 交易日与市集相比:涨幅强于大盘''),COLOR00EEff;
IF DISPSTATUS=2 and 一份市集。 THEN
DRAWTEXTREL(10,570,最近, numtostrn(N,0) 交易日与市集相比:弱于大盘,COLOR00EEff;
IF DISPSTATUS=2 THEN
DRAWTEXTREL(10,650,市集行情下跌:”+NUMTOSTRN(大盘,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN
DRAWTEXTREL(10,730,一份累计下跌:”+NUMTOSTRN(个股,3)),COLOR00EEff;
IF DISPSTATUS=2 THEN
DRAWTEXTREL(10,810,比市集: numtostrn(我,0) ‘日’),COLOR00EEff;
IF DISPSTATUS=2 THEN
DRAWTEXTREL(10,890,表示不佳:”+NUMTOSTRN((N-i),0) ‘日’),COLOR00EEff;

STICKLINE(INDEXA>0 and
INDEXOSTICKLINE(INDEXA>0 and
INDEXO>INDEXC,INDEXC,INDEXO,6,0),COLORGREEN;
STICKLINE(INDEXA>0 and
INDEXOSTICKLINE(INDEXA>0 and
INDEXO>INDEXC,INDEXH,INDEXL,1,0),COLORGREEN;
忘却你说,限制元素n可以鉴于本身的需求设置。,n数是一份与市集的相比,我在嗨缓缓浮夸的的了20天。,让咱们做你喜爱做的事实。

———————————————————————————————

回答:

O2:=(C / REF(C,1)-1); 
  
 O1:=(INDEXC/REF(INDEXC,1)-1);
K1:=IF(O1>(O1<)); 
 
βB:=K1*(O2-O1)*100; 
 石器时代的:(b),5); 卡伊:EMA(石),5);
DRAWICON(CROSS(石,开),石,3);
恢复:谢谢你楼上的,它是技能的目标。!!!

———————————————————————————————-

阶段巨大

{日大盘接受股收天数
B;N天中大盘关线的天数
D:A / B
D值越大,在这一阶段的一份浮现越强
n=20;

答:=计数(C > O AND
INDEXCB:=计数(INDEXCD:A / B;

{看大盘一份一份的巨大
}
1。人家好的一份必需提早大盘
2。首要的大盘它可以分为两方法型:一是多大盘疾速升起,二是多大盘抗跌,进行要 记得指挥大盘

必然能赚钱哦。
三.可以有加无已弹回,细细品味,它能任务很长时期。

DRAWGBK(DATE>900101,COLORRGB(0,15,13),COLORRGB(0,0,0),1);
RSV:=(c-llv(L,49))/(HHV(H,49)-LLV(L,(49))×100;{改变线KDJ变}
变体:= SMA(RSV),100,99);{ KDJ多样化K线}
1短:= SMA(变体,3,2){浮夸的等比中数}
1基层:= SMA(短1),8,1){浮夸的等比中数
fillrgn(短1<中1,短1,中1),Color6EBB6E;
fillrgn(短1>中1,短1,中1),ColorD6A6FF;
1短:短,PRECISION2,ColorFF00FF;
在:1,PRECISION2,Color00FFFF;
SMA(短1圈)的巨大,120,1),PRECISION2,LINETHICK2,color009c00 { };浮夸的等比中数
LC := REF(C,1);
LCDP:= REF(INDEXC,1);
一份:SMA(max(C-LC,0),14,1)、SMA(ABS(C-LC),14,1)

*100,PRECISION2,LINETHICK2,Color0000FF;
大盘SMA(max(indexc-lcdp,0),14,1)、SMA(ABS(indexc-lcdp),14,1)

*100,PRECISION2,LINETHICK2,ColorFF0000;

强弱相抵–(大盘团体股

N=5;N1=3,n2=1(授予使有胆量),也感激原著作者
LC2:=(“1a0001$Close”+”1a0001$Open”)/2;
LC:= SMA(EMA(LC2,n),n1,n2);
答:= lc-llv(LC,5);
B:= HHV(LC,5)- LLV(LC,5);
C1(A / B * 100) 100,linethick2;
A1:= lc-llv(LC,10);
B1:= HHV(LC,10)- LLV(LC,10);
C2(100)100,linethick2;
A2:= lc-llv(LC,20);
B2:= HHV(LC,20)- LLV(LC,20);
C3:(A2/B2×100) 100,linethick2;
A3:= lc-llv(LC,30);
B3:= HHV(LC,30)- LLV(LC,30);
C4:(A3、B3×100) 100,linethick2,colorblue;
kLC2:=(Close+Open)/2;
KLC:= SMA(EMA(klc2,n),n1,n2);
嘉:=(KLC KLC LLV,5);
KB:= HHV(KLC,5)- LLV(KLC,5);
氯化钾:(KA / KB * 100)- 10,colorwhite,linethick2;
kA1:=kLC-LLV(kLC,10);
KB1:= HHV(KLC,10)- LLV(KLC,10);
kC2:(kA1/kB1*100)-10,linethick2,coloryellow;
kA2:=kLC-LLV(kLC,20);
KB2:= HHV(KLC,20)- LLV(KLC,20);
kC3:(kA2/kB2*100)-10,linethick2;
卡:=(KLC KLC LLV,30);
KB3:= HHV(KLC,30)- LLV(KLC,30);
kC4:(kA3/kB3*100)-10,linethick2,colorblue;
stickline(c,95,95,8,1),colorgreen,linethick2;

机械的公众之敌——成立力气的相比

dpjj:=(2*INDEXC+INDEXH+INDEXC)/4;
ggjj:=(2*c+h+l)/4;
dpzd:=(dpjj-ref(dpjj,1))/REF(dpjj,1)*100;
ggzd:=(ggjj-ref(ggjj,1))/REF(GGJJ,1)*100;
cy:ggzd-dpzd,VOLSTICK;
pjzy:EMA(CY,n);
cqpj:EMA(CY,55);
0;
20;
-20;
和(CY,13),COLORred;
和(CY,55),coloryellow;
ph:ema(和(CY,55),34),colorgreen;
试着回答朋友们的成绩:
1,核心成绩是一份价格目录运转射中靶子生活功能。,这是看手指。

更有理的姿态

   编制了一份目录和鉴于s的辅佐一份选择公式集。。
dpjj:=(2*INDEXC+INDEXH+INDEXC)/4;
ggjj:=(2*c+h+l)/4;
dpzd:=(dpjj-ref(dpjj,1))/REF(dpjj,1)*100;
ggzd:=(ggjj-ref(ggjj,1))/REF(GGJJ,1)*100;
cy:ggzd-dpzd,VOLSTICK;
pjzy:EMA(CY,n);
cqpj:EMA(CY,55);
0;
20;
-20;
和(CY,13),COLORred;
和(CY,55),coloryellow;
ph:ema(和(CY,55),34),colorgreen;
即将到来的东西真正很复杂,是一份和大盘一种相比优点和长处的方式——坦率地与左右相抵

相比,这马上我所想的。
一份价格相比微弱。,对立于支持物一份,对立于大盘。在一份价格呈现激烈的高程度

前,有人家渐进的媒质巨大的审核。,也执意说,对立大盘的弱势,不落,不落

。因而CY:ggzd DPZD,volstick;这句话
这是相比的根底。。
 作为一种流传滤波杂波方式,人家是等比中数数。,人家是积聚的。
pjzy:EMA(CY,n);
cqpj:EMA(CY,55);
执意等比中数
和(CY,13),COLORred;
和(CY,55),coloryellow;
只基金,对立来说,基金更着手处理渐进设计的理念。
ph:ema(和(CY,55),34),colorgreen;
有人家轻易的边界附近的来测量图一份价格的巨大。
——————-
竟,它可以更复杂,这是去职的元素,这也人家对立相比。,大盘拮据非常的

,他缺乏换衣率
但你可以应用弄翻和它的5天10天是在做生水垢。,完全地可以试试。
——————————————————————————————–

版本:= EMA(C,5)/EMA(C,20);AR2:=EMA(INDEXC,5)和EMA(INDEXC,20);
Ar3:= EMA(V,5)/EMA(V,20);AR4:=EMA(INDEXV,5)和EMA(indexv,20);
领头羊股票:(AR1 / ar2-1)* 100
———————————————————————————————

=(翻开 高 关 低)/ 4

型:=马(SM,D);

IM:=(indexo+INDEXh+INDEXL+INDEXC)/4;

酰亚胺:=马(IM,D);

SI1:=(SMID-REF(SMID,1))/型

二:=(imid-ref(IMID,1))/酰亚胺

RADER1:SUM((SI1-II)*2,S)*1000,linethick3,COLORRED;

RADERMA:SMA(RADER1,M,1),linethick3;

静态:EMA(atan((rader1 REF(rader1,3))/3 )*180/);

OL: 0,linethick1,COLORWHITE;

比强:RADER1/RADERMA;

我用的

————————————————————————————————–

买强势股,另一大一份巨大目录,了如指掌

{大盘个股强与弱}
个股:(C-REF(C,1))/REF(C,1)*100,COLORRED,LINETHICK1;
大盘:(INDEXC-REF(INDEXC,1))/REF(INDEXC,1)*100,COLORBLUE,LINETHICK1;
STICKLINE(个股>=大盘,个股,大盘,1,0),COLORRED;
STICKLINE(个股<大盘,个股,大盘,1,0),COLORBLUE;
STICKLINE(个股>=大盘,0,大盘,1,0),COLORYELLOW;
STICKLINE(个股<大盘,0,个股,1,0),COLORGREEN;

NameE-mailWebsiteComment

发表评论

电子邮件地址不会被公开。 必填项已用*标注